Inicio > programación, web > Lightbox 2 no funciona en Internet Explorer 9

Lightbox 2 no funciona en Internet Explorer 9

Jueves, 14 de Abril de 2011


Así de rotundo es, tal como dice el título de este artículo: Lightbox 2 no funciona en Internet Explorer 9. El recién estrenado navegador de Microsoft no se lleva bien con Lightbox 2, provocando que muchas webs no funcionen correctamente si navegamos con Internet Explorer 9. Y con el resto de navegadores? Pues sin problemas!!!

Lightbox es una aplicación JavaScript que permite crear diálogos modales como puede ser la clásica visión ampliada de una foto de una manera muy sencilla y rápida.

Bueno, vamos al grano… No puede ser que ahora nuestras webs no funcionen con el navegador más nuevo de Microsoft. Y no nos pueden obligar a cambiar código por eso! Así que aquí presento una solución fácil y rápida:

  • Insertar dentro de los tags “head” la siguiente línea: <meta http-equiv=”X-UA-Compatible” content=”IE=7″ />

De esta manera habilitaremos la compatibilidad con Internet Explorer 7 (en el que no había problemas con Lightbox, al igual que la versión 8) y quedará todo resuelto.

Esta solución también es válida para otros problemas parecidos con códigos JavaScript.

¿Te gustó el artículo? Compártelo!!:
  • Facebook
  • Twitter
  • FriendFeed
  • del.icio.us
  • LinkedIn
  • Technorati
  • Ping.fm
  • StumbleUpon
  • Google Bookmarks
  • Digg
  • Meneame
  • Netvibes
  • Live
  • BarraPunto
  • Bitacoras.com
  • Reddit
  • Wikio
  • email
  • Print

A. Montes programación, web , ,

  1. Jueves, 5 de Mayo de 2011 a las 15:51 | #1

    Probe el cambio que planteas y nada. Checa la web http://www.piederecho.pe en la sección chambas.

  2. Martes, 31 de Mayo de 2011 a las 10:42 | #2

    Hola Luis, perdona el retraso… pero es que ando muy liado. He estado mirando tu web, pero posiblemente cuando ya has quitado el tag que comenté en mi artículo. Así que no he podido comprobarlo. Cómo va?

  3. Domingo, 13 de Noviembre de 2011 a las 18:08 | #3

    Hola Luis, disculpa pero quería saber que agregaste para que tu lightbox funcione con el IE9 ? Muchas gracias! R.

  4. Domingo, 13 de Noviembre de 2011 a las 18:51 | #4

    Hola Roni.
    Con lo publicado en el post no te ha funcionado bien en IE9?

  5. Sábado, 7 de Enero de 2012 a las 19:47 | #5

    No funciona tu meta. ¿Habéis encontrado alguna solución?

  6. Lunes, 16 de Enero de 2012 a las 20:36 | #6

    Yo la probé en una web comercial y me funcionó a la primera, por eso publiqué el post. He estado haciendo pruebas y mirando alguna otra web y no he encontrado el motivo del fallo ni la solución aplicable a cualquier caso. Lo siento.

  7. Martes, 31 de Enero de 2012 a las 22:22 | #7

    Hola!!!
    Te debo la vida, Mil y una de gracias!!!! Vales ORO!!! Me has ayudad muchisimo, el caso es que tarda un tiempo en funcionar el codigo.. .en hacer efecto, espero que una vez funciona, funcione a la primera para todas las visitas!

    Te queria preguntar si se puede poner que sea de IE8 ?

    Y de nuevo muchas gracias por la ayuda :)

  8. Domingo, 5 de Febrero de 2012 a las 19:10 | #8

    De nada, me alegro de que te haya servido de ayuda. Sí, también se puede poner de IE8. Saludos!

  9. Miércoles, 14 de Marzo de 2012 a las 17:52 | #9

    Hola!!!, muchas gracias por la solución al problema. Yo cambié el 7 por 8 y funciona correctamente. Siempre complicándonos la vida, no hay ningún navegador que de tantos problemas como IE.
    Muchísimas gracias.

  10. Jueves, 15 de Marzo de 2012 a las 20:46 | #10

    De nada! Me alegro que os haya servido de ayuda a todos. La verdad es que lo de los navegadores es de juzgado de guardia… sobre todo IE. Aunque todo se encamina hacia una estandarización…

  11. Martes, 8 de Mayo de 2012 a las 05:46 | #11

    A mi no me funciono, lo que tuve que hacer solamente es , ir a http://lokeshdhakar.com/projects/lightbox2/ y bajar la nueva version 2.51 , luego reemplazas los archivos JS y tambien los CSS por las dudas (aunque pienso que con los JS alcanza )..espero les sirva y si no me envian un mensaje por twiter. bye

  12. Lunes, 4 de Junio de 2012 a las 13:47 | #12

    No me funciona el ligthbox en IE9, alguna nueva solución??

    Puse el meta indicado pero nada que ver, les dejo el enlace y a ver si alguien me ayuda porfa!!!

    http://arratiakoinmobiliaria.com/dima.php?page=dima&lang=es

    Muchas gracias

  13. Martes, 11 de Septiembre de 2012 a las 20:32 | #13

    Imposible, no me funciona. No existe alguna alternativa para que funcione en IE9?

  14. anuar
    Miércoles, 14 de Noviembre de 2012 a las 19:57 | #14

    Muchas Gracias yo tenia ese problema y cambie e 7 Mil Gracias

  15. Miércoles, 5 de Diciembre de 2012 a las 08:24 | #15

    Gracias Pablo por tu aporte!!

  16. Miércoles, 5 de Diciembre de 2012 a las 08:25 | #16

    Hola Arratia! Pablo indica que descargando la nueva versión de Lightbox (la 2.51) se solucionan los problemas. Pruébalo y nos informas. Saludos!

  17. Miércoles, 5 de Diciembre de 2012 a las 08:26 | #17

    Hola nico! Pablo ha indicado que bajando la nueva versión de Lightbox (2.51) se solucionan los problemas. Pruébalo y nos cuentas.

    Saludos

  18. Miércoles, 5 de Diciembre de 2012 a las 08:27 | #18

    De nada anuar!

  19. Alejandro
    Viernes, 19 de Abril de 2013 a las 14:37 | #19

    Disculpen no les funciona porque esta mal puesta una comilla les dejo el script que funciona

    saludos Alejandro

  1. Sin trackbacks aún.